The PPD Reform Tracking Tool

A tutorial to use a tool designed to manage, track and report on Working Groups’ issues
1- INTRODUCTION ....................................................................................................................... 3
2 - BROWSING INFORMATION .................................................................................................... 4
   OPEN A DATABASE AND MOVE BETWEEN RECORDS ................................................................. 5
   VIEW INFORMATION IN DIFFERENT WAYS .............................................................................. 5
   VIEW YOUR LAYOUTS AS FORMS, LISTS, AND TABLES. YOU CAN VIEW YOUR LAYOUTS IN THREE DIFFERENT WAYS: AS A FORM, AS A LIST, AND AS A TABLE. .................................................. 6
3 - EXISTING LAYOUTS ............................................................................................................. 6
   ISSUE FILING LAYOUT ................................................................................................................ 7
   ALIGNMENT WITH WB INDICATORS .......................................................................................... 9
   THIS LAYOUT ONLY RETRIEVES THE WORKING GROUP, REFORM NUMBER, REFORM TITLES AND INDICATORS ................................................................................................................................................................. 9
   LISTS OF REFORMS IN NUMERICAL ORDER ......................................................................... 9
   LIST OF REFORMS PER WORKING GROUP ............................................................................... 9
   LIST OF REFORMS PER SUBMITTER TYPE ............................................................................... 9
   POTENTIAL IMPACT OF PROPOSED RECOMMENDATIONS PER REFORM .............................. 10
   POTENTIAL IMPACT OF PROPOSED RECOMMENDATIONS PER WORKING GROUP .............. 10
   ACTION ITEMS AND JURISDICTIONS ....................................................................................... 10
4 - CUSTOMIZING THE EXISTING LAYOUTS .............................................................................. 10
   RESIZE, MOVE, AND ADD A FIELD .......................................................................................... 11
   DISPLAY A NUMBER AS CURRENCY .......................................................................................... 12
   MODIFY THE ORDER OF COLUMNS IN TABLE VIEW ............................................................. 12
   CLICK ON THE DOUBLE ARROW TO MODIFY THE ORDER OF COLUMNS. UNCHECK THE BOXES TO MAKE SOME FIELDS DISAPPEAR ......................................................................................................................... 13
   CHANGING THE VALUE LISTS OF THE PRE-DEFINED FIELDS ............................................. 13
   CREATING NEW REPORTS BESIDE THE EXISTING ONES .................................................... 14
   GENERATE A REPORT WITH GROUPED DATA AND TOTALS .................................................. 14
5 - ENTERING RECORDS ........................................................................................................ 16
   CREATE THE FIRST RECORD ..................................................................................................... 16
   CREATE ANOTHER RECORD ..................................................................................................... 16
   MODIFY DATA IN A RECORD ................................................................................................... 16
   DELETE A RECORD ................................................................................................................ 16
   INSERT A RECORD IN THE CONTAINER FIELD ...................................................................... 16
6 - FINDING AND SORTING RECORDS .................................................................................... 17
   FIND RECORDS BASED ON CRITERIA IN A SINGLE FIELD ..................................................... 17
   FIND RECORDS BASED ON CRITERIA IN SEPARATE FIELDS .................................................... 17
   FIND RECORDS THAT MATCH MULTIPLE CRITERIA IN THE SAME FIELD ............................ 18
   FIND RECORDS THAT MATCH A RANGE OF CRITERIA IN THE SAME FIELD .......................... 18
   NARROW YOUR SEARCH ......................................................................................................... 19
   SORT YOUR FOUND SET .......................................................................................................... 20
7 - EXCHANGING DATA ............................................................................................................ 20
   SAVING RECORDS IN EXCEL OR PDF OR EXPORTING ONLY SOME FIELDS ...................... 20
   IMPORTING DATA ................................................................................................................ 21
7 - PROTECTING DATA ............................................................................................................. 22
   CREATE AN ACCOUNT AND PASSWORD .................................................................................. 22
   CREATE A PRIVILEGE SET ....................................................................................................... 23
1- Introduction

PPDs are expanding in several countries and each one can take on its own form. However the facilitator faces the same challenges in each PPD which is dealing with the follow-up of all the working groups in the same time and manage them in an efficient way in order for the PPD to succeed.

The tutorial presents the tool designed to help facilitators in this task. This is a management tool for issues raised by working groups.

This tutorial shows how you can manage issues’ information in the tool:

You will learn how to use it to:
- locate and sort issues’ information
- create and enter issues’ records in a simple database
- run existing reports and modify them
- learn how files can be shared with other users on your network or over the Internet
- protect information in your database by assigning user accounts and privilege sets and by backing up your databases

The tool is built on the software FileMaker Pro 10.
8 Layouts were already designed for the purpose of effective management of working group issues.
- Issue Filing
- Alignment with World Bank Indicators
- Number of Issues per Submitter Type
- List of reforms in numerical orders
- List of reforms per working group
- Potential impact of proposed recommendation per reform and working group
- Action items and jurisdiction

These layouts were designed upon needs assessment with facilitators but must be subject to change to match your local PPD situation.

You can work with these 8 layouts in one of four modes.
- Use Browse mode to enter data and view records.
- Use Find mode to locate a record or a group of records quickly.
- Use Layout mode to specify how information will appear on the screen or when you print it.
- Use Preview mode to see what the pages will look like when you print them.

Once you have opened a database, you can switch from one mode to another using either the View menu or the mode pop-up menu at the bottom of the application window.
2 - Browsing information
You view, enter, or change data in Browse mode. This is the simplest way to interact with your database. In particular through this mode you will:

- open a database with data already in it
- move between records
- view information in different ways by switching layouts
- see the difference between form view, list view, and table view
Open a database and move between records

To open the database:
1. Open Issue the PPD Reform Tracking Tool
2. Notice that the database is in Browse mode. FileMaker Pro defaults to Browse mode when a database is opened.

In the status toolbar, notice that a specific record is displayed.
3. In the status toolbar, click the right page of the icon to move forward one record at a time, and click the left page to move back one record at a time.
4. Drag the slider to the right and release to move forward a number of records at one time. Drag the slider to the left and release to move backwards a number of records.

You can also click the current record number, type the record number you want, then press Enter.

Tip The Records menu also provides commands to move between records. Choose Records menu > Go to Record and choose either Next, Previous, or Specify.

View information in different ways:

Even though you enter information only once in FileMaker Pro, you can use that information in many ways. The different layouts let you view some or all of your fields.

See a different layout

1. Click the Layout pop-up menu. A list appears showing the layouts available in this file.
2. Notice the check mark next to the Issue Filing layout, your current layout. The Issue Filing layout shows all of the fields in the table.
3. Choose the List of reforms in numerical order in the Layout pop-up menu.

The report is based on the Issue Filing layout but only retains the reform number and title. However, no data has been removed from the database.
**View your layouts as forms, lists, and tables. You can view your layouts in three different ways: as a form, as a list, and as a table.**

- Form view displays your current layout one record at a time.
- List view shows your current layout as a list, with one record appearing beneath another.
- Table view shows you many records at one time in a grid.

Layouts can be toggled between form view, list view, and table view while the database is in Browse mode, by going to the View Menu> View as Form or View as List or View as Table. Or by clicking on the view icons:

Not all the views are available for all the existing layouts that you see. You can manage the options by going to File > Manage>Layouts. Click on layout set up and check the view that you want for a specific layout in the View table.

### 3 - Existing layouts

8 Layouts were designed for the purpose of effective management of working group issues.

- Issue Filing
- Alignment with World Bank Indicators
- Number of Issues per Submitter Type
- List of reforms in numerical orders
- List of reforms per working group
- Potential impact of proposed recommendation per reform and working group
- Action items and jurisdiction
**Issue Filing Layout**

This first layout is intended to be fed with all the information concerning an issue. This is the Data Entry Layout.

The layout is divided into 6 pages

**Page 1:**

1. **Background Information of the Issue submission**
   - Working Group Name: A drop-down list is set with a value list which is predefined but can be modified. *(See section 3).*
   - Submitter Name and Contact Details
   - Submitter Type which can be a private company, a State, an NGO or an International Agency representative – those types have to be specified in the appropriate fields.
   - The number of the Issue is generated automatically
   - Economic Sector of the Issue
   - The Submission Date of the Issue
   - The current status of the issue which is specified into: - current agenda; solved positively (= in line with recommendation of the PS); solved negatively (government say no to it); is outdated (circumstances have changed); on hold (the government refuses, or doesn't have an answer or larger framework needs to be put in place before solving this issue) and has been reformulated
   - If the issue was solved, the date of it.

2. **Issue Details**
   - Reform Title
   - Reform Type
   - Issue Summary

**Page 2:**

Economic Cost and problems of the current situation: here a description of the problems of the current situation has to be given
Page 3:
1- Proposed Recommendations:
Here describe the proposed recommendations
2- Potential Impact of the proposed recommendations
Try to assess the potential savings and cost of the proposed recommendations

Page 4
Action Plans: give specifically the action plan by giving law names and numbers that have changed or that are subject to change. Specify for each action plan, the jurisdictions that have been resorted to.

Page 5:
Reform Process and indicators:
- Select one of the options concerning the progress of the issue in the Reform Process.
- Check the boxes for the WB Indicators
Three types of World Bank indicators have been set up: Doing Business; Enterprise Survey Topics; Business Enabling Environment products.
Select on each box to what extent the issue which is raised and tackled by this working group is in line with each type of indicators.

Page 6:
Attach the key – documents related to the reform in this page.
**Alignment with WB Indicators**

This layout only retrieves the working group, reform number, reform titles and indicators. This layout can be exported to excel in order to calculate statistics on the alignment with WB indicators. The table view reflects what could be seen on excel.

**Lists of reforms in numerical order**

This layout only retrieves all the reform and their reform number. Push the button “sort per reform number” to have them sorted by reform number. This layout is available only in list view.

**List of reforms per working group**

This layout only retrieves all the reforms grouped per working group. Push the button “sort per working group” to see the data correctly. This layout is available only in list view.

**List of reforms per submitter type**

This layout only retrieves counts the number of issues submitted by submitter type. Push the button “sort per submitter type” to see the data correctly. This layout is available only in list view.
**Potential Impact of Proposed Recommendations per Reform**

This layout only retrieves the impact of proposed recommendations per reform. This layout is available only in list view.

**Potential Impact of Proposed Recommendations per Working Group**

This layout only retrieves the impact of proposed recommendations per working group and for the whole PPD. This layout is available only in list view.

**Action items and jurisdictions**

This layout is interesting to get a better idea of the reform process: exported to excel the table view will allow to know how many action items were submitted to each jurisdiction.

*These layouts can be customized to be adapted to local needs. See the following section for that.*

### 4 - Customizing the existing layouts

Design layouts in *Layout mode*. You can include any combination of fields, text, and graphics on a layout. You can change the font and color of fields and text and you can change the way data appears in Number or Date fields. For example, you can set a Number field to include currency notation or you can set a Date field to include the day of the week with the month, day, and year.

Changes you make in Layout mode affect only the way data appears. The data itself remains as it was entered.
The existing layouts were designed according to a needs assessment but you may think that they are to be customized to your local needs. This section expounds how to do it.

**Resize, move, and add a field**

**Select and resize a field**

1. Choose View menu > Layout Mode or click on the edit layout button on the right of the window:

2. In Layout mode, click the field to customize, to select it.
3. Drag the handle at the lower-right corner of the field to the left until the field is smaller, yet large enough to display the longest data you expect in your file.

4. Click Save to save changes to this layout, if prompted.

FileMaker Pro can save layout changes automatically, or prompt you to save changes before leaving Layout mode. To save layout changes automatically, select the Save layout changes automatically checkbox in the Save changes to this layout dialog box.

5. Choose View menu > Browse Mode or exit layout: In Browse mode, flip through the records.

If the field doesn’t display all names completely, return to Layout mode and make the field larger.

**Move a field**

1. Choose View menu > Layout Mode or click on the edit layout button on the right of the window:
2. Click inside a field and drag it beside another field
3. Press Shift and click both fields to add it to your selection. Both fields are selected.
4. Choose Arrange menu > Align > Top Edges.

Fields move until they are aligned at the top

**Add a field and choose its format**

If a field has been defined in a table, you can display it on any layout based on that table. Here the table is called “Issue Filing”.

11
1. Choose View menu > Layout Mode.
2. Using the Field tool, drag the field to layout and on the layout drag from the top left corner to the bottom right corner,

![Image of FileMaker Pro layout mode]

3. In the Field/Control Set-up dialog box, in the “display data from” drop down list select the needed field, then click OK.
   The new field appears on the layout.

   ![Image of Field/Control Set-up dialog box]

4. Resize the new field by dragging a right handle so the field is the same size as the others
5. Right click on the field to arrange the format
6. Select Size, Style, and Color in the text format
7. You can also change the fill color, pattern or the pen color or pattern

**Display a number as currency**

You can display a number as currency, even though only the number is typed into the field. Formatting affects only the way data is displayed. It does not change the data.

1. Choose View menu > Layout Mode.
2. Select a quantitative field.
3. Choose Format menu > Number
4. Select options in the following Number Format dialog box as shown

5. Click OK.

**Modify the order of columns in Table View.**

The table view design can not be modified. It retrieves the font and colors of the fields of form view. The only option given in table view is to modify the order of column and to make fields appear or disappear.

This can be done in browse mode by clicking on the “Modify button”
Click on the double arrow to modify the order of columns. Uncheck the boxes to make some fields disappear.

**Changing the Value Lists of the Pre-Defined Fields**

*Value lists* let you choose the value you want from a scrolling list, a pop-up menu, checkboxes, or radio buttons. The lists *Working Group, Reform Process Status, Type of current status* contain predefined values but they are to be changed to correspond to the local context.

1. Choose Issue Filing from the Layout pop-up menu if it is not already selected.
2. Choose File menu > Manage > Value Lists.
   You can also click on the “Manage icon” of the layout mode on top of the exit layout button
3. Click on one of the Value List that you want to change.
4. Click Edit
5. Click in the large box and change the values for this list, by typing each value on its own line.
6. Click OK to finish

**Assign a value list to a field and display it as radio buttons for example**

You can also decide to assign value lists to other fields or change the type of button

1. Choose View menu > Layout Mode.
2. Select the Issue Filing Layout, if it is not already displayed.
4. Choose Format menu > Field/Control > Setup or Right Click and choose Field/Control > Setup
5. For Display as, choose Radio Button Set for example
6. For Display values from, choose Manage Value Lists…
7. Click New
7. Give a name and custom values
9. Click OK

**Creating New Reports beside the Existing ones**

You may want to create new reports that are not predefined and in particular "subsummary" reports. *Subsummary reports*, also referred to as *reports with grouped data*, categorize information by a particular field or fields, allowing you to group information hierarchically. This subsummarized information can then be subtotaled, averaged, or counted.

1. In Layout mode, choose Layouts menu > New Layout/Report or click on the icon New layout/report on the status tool bar.

2. Type a Layout Name and select the list/report layout type
3. Select Report with grouped data, and click Next.
4. Select the fields to be used in this report and move it to the Layout fields list.
   For example, working group, reform type, reform status
5. Click Next
6. Move the field according to which the Report categories list will be organized. Working group for example
7. Click Next
8. You can move a second field to order the records in the Sort Record step, but this is optional. In this same window, you define the sorting order type as well: ascending, descending, customized based on value list or summary field (see below for summary field definition)
9. Click Next
10. Select a theme and create the header and footer.
11. Create a script to run the report if desired
12. Click View the report in Preview mode if it is not already selected.
13. Click Finish.

**Generate a report with grouped data and totals**

Previously we saw how to create a report that grouped data in categories based on common field values. It is also possible to create a similar report that also includes subtotals for each category and a grand total for the entire report.

You may want to know for example the costs or savings for proposed recommendations by working group. A report with grouped data and totals requires the same elements as a report with grouped data: a sub-summary part in the report layout for each category, a field or fields to group records by, and a sort of the database by these fields.
1. Repeat step 1,2,3 of former paragraph
4. Select Report with grouped data and then select Include subtotals and Include grand totals.
5. Click Next
6. Select the fields to be used in this report such as for example Working Group and Savings/Costs and click Next
7. Select the field by which you want to summarize data such as Working Group and click next
8. Select the fields for the Sorting Records if any, pick up the sorting order type and Next
9. In the “Specify subtotals” step, you have to pick the quantitative field that will be the basis for the subtotals. These fields are called “summary fields”. In this example you can only pick up total costs or/and total savings.

Note: These fields are the only ones available because they have been specified as “summary field”. They have to be specified as so to be used as subtotals and grand totals. A summary field is a type of field you can specify when you define fields. Summary fields allow calculations across all of the records in your found set. In general, when you need to total data across a number of records, you must use a summary field. In File>Manage>Database, a summary field that totals the costs and savings entered in the corresponding field can be created.

Here, we suggest a report based on subtotals for cost or savings or potential ones by working group and to see a grand total of both types’ economic impacts at the end of the report.

10. For Category to summarize by, use Working Group
11. For Subtotal placement, use the default value of Below record group.
12. Click Add Subtotal to add the Current Status Type field as the subtotal. This tells FileMaker Pro to create a subtotal of Costs or Savings that are beneath each current status step.
13. Click Next
14. In the “specify grand total step”, for Summary field, click Specify and select Total savings or/and costs from the list of available fields, then click OK.
15. Click Add Grand Total to add the Total Costs or Savings as the grand total at the end of the report. This tells FileMaker Pro to create a grand total of costs or savings
16. Click Next
17. Select a Theme for the layout design and create headers and footers
18. Create a Script if desired.
19. Go to layout mode, to modify the design

INote: Reports with grouped data are interesting to see on List View and Table view.
IMPORTANT: In list view, the data will appear correctly only if you sorted the records according to the grouping category first (working group).

5 - Entering records

Create the first record
1. In Browse Mode Press “New Record” on the tool bar status to begin the data entry.

2. Select the Name of the Working Group in the Working Group field.
3. Press Tab to move to the next field.
4. Type the Name of the Submitter
5. Press Tab to move to the next field and so on..

Create another record
1. Choose Records menu > New Record or Click “New Record”
2. Click the book icon to see each record.

Modify data in a record
Suppose you realize that your Working Group is not Tourism but Tax. You can easily correct the entry.
1. Go to the record.
2. Select a new name in the Working Group field
3. Click an empty area outside the field to save the change.

Delete a record
1. Go to a record that you created.
2. Choose Records menu > Delete Record or click Delete
3. Click Delete in the confirmation dialog box.
Notice in the status area that only two records remain in the database.

Insert a file in the container field
In the “container field” you can store pictures, QuickTime files, sounds you record, or any other type of file that you want to track in a database.
1. Select the container field.
2. Choose Insert menu > File.
3. Click Open.

When you insert a file, FileMaker Pro displays the file's icon and name in the container field but not the actual content of the file.

6 - Finding and sorting records

Your database is a collection of records. Sometimes you will work with all of the records in the database. Often, however, you will work with a subset of your database—issues from a particular working group or issues that fall within a particular range of dates.

In FileMaker Pro, this process of searching for records that match particular criteria is called finding records. Once you’ve found the records you want to work with, you can change their order by sorting them. Records can be sorted in ascending or descending order.

In particular you will:

- find records matching criteria in a single field and multiple fields
- find records matching a range of data
- narrow your searches by omitting records
- sort records in ascending and descending order

Find records based on criteria in a single field

In the database, find all of the issues that are from the Working Group Tourism.

Go to find mode:

1. Click on the Working Group field. Find the tourism working group
2. From the status toolbar, click on perform find.
3. Click the book icon or slider to view each of the records in the found set in browse mode.

Find records based on criteria in separate fields

You can find records that match multiple criteria, for example issues which are from the Working Group Tourism and candidates for the current Agenda.
This type of search is commonly referred to as an AND search. To perform an AND search in FileMaker Pro, type each search criterion directly into the appropriate field in Find mode.

To find all issues which belong to the Working Group Tourism and are candidate to the current agenda:

1. Choose View menu > Find Mode.

Use Find mode to perform more advanced searches. In Find mode, you create a find request using the fields in the layout you see. Type the criteria you want to search for directly into the fields on the request.

2. Choose Tourism in the Working Group field.

3. Choose Current Agenda in the Type of Current Status

4. Click the Perform Find button in the status area.

5. Results are given in Browse Mode

**Find records that match multiple criteria in the same field**

Sometimes you need to find records that match more than one criterion in a single field. For example, you may need to find all members located in either the Working Group Tourism or the Working Group Law and Tax. This type of search is commonly referred to as an OR search, because your found set will consist of records that match any one of the find criteria.

To perform an OR search in FileMaker Pro, you will need to use multiple find requests.

- Type the first search criterion into the appropriate field of the first find request.
- Create a second find request and enter the second search criterion in the same field.

When you click the Find button, FileMaker Pro will retrieve all of the records that match any of the criteria you’ve entered.

To find all the issues belonging to the Tourism or Tax Working Groups:

1. Choose View menu > Find Mode.

2. Type Tourism in the Working Group field.

3. Choose Requests menu > Add New Request or click on the “New Request” icon of the status tool bar

4. Type Law and Tax in the Working Group field of this second request.

5. Click Perform Find in the status bar.

6. Results are given in Browse Mode

**Find records that match a range of criteria in the same field**

Sometimes, you might want to find records that match a range of criteria within a single field. For example, you might want to find all of the records that fall within a one-month
period, or locate all of the issues with a potential economic cost between $500 and $1000.

To perform this type of search in FileMaker Pro, you use a special range symbol in your find request to specify the lower and upper limits of your find criteria. To find the issues who were raised between January 1, 2007 and June 30, 2007:

1. Choose View menu > Find Mode.
2. Type 1/1/2007 in the Submission Date field.
3. Right Click and Choose the operators pop-up menu. Select “range” from the list, or type an ellipsis (...).
5. Click Perform Find

*The operators menu allows to conduct advanced search with refined criteria on any field.*

**Narrow your search**

Sometimes, you might need to find records that match certain criteria while at the same time excluding others (for example, finding all of the issues that were added in a given year except for those added in February). You can perform these types of finds by using a combination of multiple find requests and omitting certain records.

Because FileMaker Pro processes multiple find requests in the order they are created, it is possible to create very specific, layered searches in this manner. Omitting records in a search does not delete them from the database.

To find the records of issues who were raised in the first six months of 2007, except for those which were raised in February:

1. Choose View menu > Find Mode.
2. Type 1/1/2007 in the Submission Date field.
3. In the status area, click the Operators pop-up menu. Select range from the list, or type an ellipsis.
5. Choose Requests menu > Add New Request.
6. Type 2/1/2007 in the Submission Date field.
7. In the status area, click the Operators pop-up menu and select range from the list, or type an ellipsis.
8. After the ellipsis, type 2/29/2007 in the Submission Date field.
9. Click Omit in the status area.
10. Click Perform Find

**Sort your found set**

Once you have a found set of records to work with, you might want to sort those records. For example, you might want to display the records in alphabetical order, or sort them from newest to oldest.

To sort records in alphabetical order by the working groups’ names:

1. Go to the Layout pop-up menu and choose the “Issue filing” layout.

2. Choose on the sorting icon of the status toolbar.

3. If any fields appear in the Sort Order column on the right side of the dialog box, click Clear All.

4. In the list of available fields, select Working Group and click Move.

Notice the sort direction symbol to the right of the Working Group field increases in size from left to right. This indicates that when the database is sorted by this field, the data will be in ascending order (from a to z).

5. Click Sort.

The Working Group are now in alphabetical order by working group name.

---

7 - Exchanging data

You can exchange information between FileMaker Pro and other applications by importing and exporting data. This is in particular relevant if you already managed your issues on an Excel Spreadsheet.

You can:

- import data into an existing FileMaker Pro file, either into a new table or into an existing table
- convert data from other applications to new FileMaker Pro files
- export data for use in other applications

**Saving records in excel or pdf or exporting only some fields**

You can save FileMaker Pro data as a Microsoft Excel file or an Adobe PDF file, allowing you to give data to users who don’t have FileMaker Pro.

You can either save all the record in excel/pdf or only part of it by selecting some fields of the record.
To export all the record with all its fields
1. Choose File menu > Save/Send Records As > PDF or Excel or click on the software icons in preview mode
2. Choose a name and Click Save

To only export some of the fields
1. Choose File menu Export records > PDF or Excel
2. Choose a name and Click Save
3. Choose the fields to export and the export order
4. If the records were sorted by a category when you started the export, this category will appear in “group by”. If you don’t want this to happen, go back to browse mode. Click on the sort button and “clear all”.

Importing data
There are several ways to import data into an existing file. You can:

- add new records to an existing table
- create a new table from imported data
- update existing records in an existing table
- update matching records in an existing table

Important Certain import operations that update existing records and update matching records overwrite existing data during the import process, which cannot be undone. To safeguard your data, always choose File menu > Save a Copy As to make a backup of the file before you perform an import that updates records.

The file you import records from is the source. The file you import records to is the target.

Import data into the file Issue Making
1. Open your file
2. Choose File menu > Import Records > File.
3. Choose the file which will be the source file.
4. Click Open.

The Import Field Mapping dialog box appears.
5. For Target, select the Table that you need to be fed by the new imported data
6. For Import Action, select one of the three options Add new records, update existing records in found set, update matching records in found set
7. Make sure that the Name fields in Source Fields are on the same row as the Name fields in Target Fields.
You can move target fields up and down in the list using the slider.

7 - Protecting data

Although your operating system includes file security features, you should use FileMaker Pro accounts and privileges to protect your data. In FileMaker Pro, you restrict which users can access a file when you protect files by defining accounts and passwords. The account name and password that users enter determine which privilege set is used. These privilege sets limit what users can do in the file.

Create an account and password

About accounts

Accounts authenticate users who attempt to open a protected file. An account includes an account name and usually a password. Accounts can be set up for individual users or you can create accounts that are shared among groups of individuals. Shared accounts are useful when you want fewer accounts to maintain and aren’t concerned with tracking individual access to a database file. However, it’s safer to create many accounts than to have multiple users share one account. Passwords are case-sensitive, but account names are not.

When you create a database, two predefined accounts are created (Admin and Guest) and three predefined privilege sets are available (Full Access, Data Entry Only, and Read-Only Access).

The Admin account is not assigned a password and is assigned the Full Access privilege set, which permits access to everything in the file. The Guest account allows users to open a file without specifying an account name, is not assigned a password, and is assigned Read-Only privileges.

Passwords and access privileges for predefined accounts can be changed.

To create an account and password:
2. Click New in the Accounts tab.
3. For Account is authenticated via, Choose FileMaker.
4. Type Account Name and password,
5. For Account Status, select Active.
6. For Privilege Set, choose [Read-Only Access].
7. For Description, type what you need.
7. Click OK.
You see the new account listed with the default Guest and Admin accounts.

9. Click OK.
An alert appears informing you that the Admin account is not password protected. You
must acknowledge this setting before FileMaker Pro allows you to continue.

10. Click Allow to close the alert.
You see the Confirm Full Access Login dialog box.

11. Type Admin for Full Access Account, leave Password blank, then click OK.
Note  For security purposes, always password-protect the Admin account in files you
create.

Create a privilege set

About privilege sets
Privilege sets specify a level of access to a database file. In addition, FileMaker Pro
allows for extended privilege sets, which determine sharing options for files.

Predefined privilege sets
Each new database file has three predefined privilege sets.

- Full Access permits accessing and changing anything in the file
- Data Entry Only permits only the viewing and entering of data
- Read-Only Access permits viewing but not changing data

In every database, there must be at least one account with the Full Access privilege set.
For security reasons, this account should have a password. You can’t change or delete
predefined privilege sets except to enable or disable their extended privilege sets, but
you can duplicate predefined privilege sets and modify the copy to use it in a different
way.

Custom privilege sets
While predefined privilege sets in FileMaker Pro provide for common types of data
access, creating unique privilege sets lets you limit access to specific aspects of a
database, such as which layouts can be viewed, which menus are available, and
whether printing is allowed.

Extended privilege sets
Extended privilege sets determine the data sharing options that are permitted by a
privilege set, such as whether a privilege set permits users to open a shared file or view
a database in a web browser.
Create a custom privilege set

Suppose your PPD relies on temporary staff at certain times of the year. This staff needs to have access to your data, but you want to prevent temporary employees from printing or exporting information in your database. You can create a specific privilege set for temporary staff that does not allow access to printing or exporting data.

2. Click the Privilege Sets tab.
3. Select the [Data Entry Only] privilege set, then click Duplicate.
4. Data Entry Only Copy is selected. Click Edit.
5. For Privilege Set Name, type for example Temp Staff.
6. For Description, type for example No printing or exporting for temp staff.
7. Clear Allow printing and Allow exporting.

Temp Staff appears in the privilege set list. This privilege set can be used by one or more accounts.

7. Click OK.
9. Click Allow to close the alert.

You see the Confirm Full Access Login dialog box.
Type Admin for Full Access Account., leave Password blank, then click OK.